php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27801 networking issue..
Submitted: 2004-03-31 08:32 UTC Modified: 2004-04-20 14:49 UTC
Votes:7
Avg. Score:5.0 ± 0.0
Reproduced:6 of 6 (100.0%)
Same Version:5 (83.3%)
Same OS:3 (50.0%)
From: ury at iptel dot by Assigned:
Status: Closed Package: Sockets related
PHP Version: 4.3.5 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ury at iptel dot by
New email:
PHP Version: OS:

 

 [2004-03-31 08:32 UTC] ury at iptel dot by
Description:
------------
i try use ilohawebmail http://ilohamail.org/ with php 4.3.5
and... it doesn't working, tcpdump says that php wait about 1 minute after pop3 server says first '+OK' during login to pop3 server...
with 4.3.3 version - no any problems.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-31 09:38 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2004-04-02 13:25 UTC] tibyke at tibyke dot hu
same scenario here with same results.

1 minute wait, then timeout without trying to authenticate to mail server (no sql connection to check user/password)

4.3.6RC1 is still buggy

regards,
tibyke
 [2004-04-05 07:00 UTC] wez@php.net
We need a short reproducing script.

My gut feeling on this is that you are doing something
wrong, but since I'm open minded, please prove that it
is broken by pasting no more than 10 lines of code,
something like the following:

echo "about to open socket":
$sock = fsockopen(...);
echo "opened socket"
$data = fread / fgets ?
echo "read first data"

Please be sure to include the POP3 server address (so
that we can check it out), and please don't include
references to your classes and other library functions;
we want the essence of the problem.

 [2004-04-05 17:06 UTC] tibyke at tibyke dot hu
4.3.6RC2 is still not good
wez@php.net, you've got mail!

t
 [2004-04-05 17:28 UTC] wez@php.net
Please, lets just have the shortest script that reproduces
the problem.
 [2004-04-06 08:01 UTC] admin at itccanarias dot org
Same problem with PHP 4.3.5. With previous versions of PHP IlohaMail works fine. This is the web server error:

PHP Warning:  fsockopen(): php_network_getaddresses: gethostbyname failed in /export/home/www/htdocs/IlohaMail/include/pop3.inc on line 233
 [2004-04-11 12:14 UTC] iliaa@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-04-12 05:06 UTC] tibyke at tibyke dot hu
the problem still exists, even with latest snapshot.

i wonder what else we could/should do besides reporting the problem, and pointing the allegedly faulty piece of code, and.

get ilohamail at www.ilohamail.org (0812), install it alongside a php >4.3.4, and you'll see what we're talking about.

if you dont want to then write an email, I'll show you the case on my box (as wez@php.net didnt even bother to reply to my mail)

regards,
tibyke
 [2004-04-12 07:31 UTC] wez@php.net
None of you have bothered to do some bug finding of your own; we don't have time to install large applications and debug them.

Please give me the shortest script that reproduces the bug, as I have asked, otherwise this report will sit and rot.
 [2004-04-18 12:53 UTC] jimmy at quadrahosting dot com dot au
To those who are experiencing this problem (on 4.3.5 and up) - do you check the result of fgets using feof? If this is the case, the feof is the cause of the delay because since 4.3.5 PHP will only return true on feof when the socket connection is closed or after the socket timeout period has elapsed. See www.php.net/feof

A quick fix is to call stream_set_timeout($sockethandle, 2) or a similarly low timeout.

Can someone confirm that this works for you?
 [2004-04-19 15:19 UTC] wez@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

See Bug #28055, and please try the next snapshot.
 [2004-04-19 20:19 UTC] tibyke at tibyke dot net
this snapshot is ok, ilohamail works ok.

thx,
tibyke
 [2004-04-19 23:24 UTC] derick@php.net
Cool, closing then.
 [2004-04-20 10:35 UTC] tibyke at tibyke dot hu
just a final question?

when will it be merged to the "main" tree?
will there come a bugfix release soon, or it will remain in snaps only, and get merged later when a main release is coming?

was it just a snapshot made for this bug, or will it be merged into any forthcoming spanshots too?

thx,
tibyke
 [2004-04-20 14:49 UTC] derick@php.net
If it's in one snapshot, it will be in later ones too. The fix will also be in a next release of PHP (4.3.7 OR 5.0.0).
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 09:05:50 2022 UTC