php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27694 child pid xxxx exit signal Segmentation fault (11)
Submitted: 2004-03-25 09:43 UTC Modified: 2004-03-26 12:30 UTC
From: jdaues at nmsu dot edu Assigned:
Status: Closed Package: Apache2 related
PHP Version: 5.0.0RC1 OS: RedHat 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jdaues at nmsu dot edu
New email:
PHP Version: OS:

 

 [2004-03-25 09:43 UTC] jdaues at nmsu dot edu
Description:
------------
When trying to display a php page, a blank page is display and in /usr/local/apache/logs/error_log, child pid xxxx exit signal Segmentation fault (11) error is noted.

# ./configure --with-apxs2=/usr/local/apache/bin/apxs --with-mysql=/usr/local/mysql

I previously had Apache 2.0.48 and MySQL4.0.18 running with PHP 4.3.4.  This error began when i moved to PHP5RC1.

I needed to update some rpms, so i did:
# rpm --upgrade libxml2-python-2.5.10-1.i386.rpm libxml2-devel-2.5.10-1.i386.rpm libxml2-2.5.10-1.i386.rpm
warning: libxml2-python-2.5.10-1.i386.rpm: V3 DSA signature: NOKEY, key ID de95bc1f

added /usr/local/lib/php to php.ini include_path





Reproduce code:
---------------
Simple PHP page:

 <?php
  echo "Hello";
  phpinfo();

 ?>
 

Expected result:
----------------
Hello and some php info


Actual result:
--------------
blank page and segmentation fault in error_log file


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-25 10:05 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
 [2004-03-26 12:30 UTC] jdaues at nmsu dot edu
not a bug
i had apache running against php4.3.4 AND php5.0.0RC1 
apparently this is not allowed
i removed the line with libphp4.so from httd.conf 
and it works
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 07:03:33 2021 UTC