php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27479 Dont report errors on domxml_open_mem
Submitted: 2004-03-03 06:02 UTC Modified: 2004-03-11 09:27 UTC
From: pet at iv dot ua Assigned:
Status: No Feedback Package: DOM XML related
PHP Version: 4.3.4 OS: FreeBSD 5.2.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pet at iv dot ua
New email:
PHP Version: OS:

 

 [2004-03-03 06:02 UTC] pet at iv dot ua
Description:
------------
Its undocumented arguments of function domxml_open_mem
but on previous version php all work.

Note: no return "well-formed" errors. 
If document not valid errors returned

Reproduce code:
---------------
//not well-formed document
$xml = '<text><tt></test>';

$dom = domxml_open_mem($xml, DOMXML_LOAD_VALIDATING, $Errors);

if(!Empty($Errors)){
	echo "Error found"
}else{
	echo "Document valid"
}

Expected result:
----------------
Error found

Actual result:
--------------
Document valid

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-03 06:10 UTC] chregu@php.net
Works for me.

Which libxml2 version are you using (phpinfo() should 
tell you that)?

chregu
 [2004-03-03 07:34 UTC] pet at iv dot ua
DOM/XML API Version  20020815  
libxml Version  20607  

Configure Command
'./configure' '--enable-versioning' '--enable-memory-limit' '--with-layout=GNU' '--with-zlib-dir=/usr' '--disable-all' '--with-regex=php' '--disable-cli' '--enable-ctype' '--with-dom=/usr/local' '--with-dom-xslt=/usr/local' '--with-dom-exslt=/usr/local' '--with-iconv-dir=/usr/local' '--with-iconv=/usr/local' '--with-mnogosearch=/usr/local' '--with-mysql=/usr/local' '--enable-overload' '--with-pcre-regex=yes' '--enable-posix' '--enable-tokenizer' '--with-expat-dir=/usr/local' '--enable-xml' '--enable-xslt' '--with-xslt-sablot=/usr/local' '--with-zlib=yes' '--with-apxs2=/usr/local/sbin/apxs' '--prefix=/usr/local' 'i386-portbld-freebsd5.2.1'
 [2004-03-03 07:51 UTC] pet at iv dot ua
Sorry.
xml must be:

$xml = '<!DOCTYPE test [ <!ELEMENT test (tt)*> 
<!ELEMENT tt (#PCDATA)> ]><test><tt></test>';
 [2004-03-06 13:52 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Works fine (prints errors found) with latest CVS. 
 [2004-03-11 09:27 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 07:01:26 2019 UTC