php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2734 pconnect works wrong
Submitted: 1999-11-17 05:24 UTC Modified: 2000-07-23 02:50 UTC
From: justice at digito dot com Assigned:
Status: Closed Package: Oracle related
PHP Version: 4.0 Beta 2 OS: redhat linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
39 - 16 = ?
Subscribe to this entry?

 
 [1999-11-17 05:24 UTC] justice at digito dot com
I used 'ora_plogon' function like this
    $conn = ora_plogon( $id, $pass );

In the same page, I try another connection to oracle
 at remote system like 
    $conn2 = ora_plogon( $id@MYTNS , $pass );

It works well at this time!!


But... 
  When I use $conn (first connection ) in some operation.
  It works as $conn2.. 
So to speak, when I use 'select..' with $conn.. ,it (php)
  finds table in remote system ...

This occurs sometimes not always..

SID and ORACLE_HOME enviroment variable are same in both
system.


I think that pconnect in oracle has some bugs...
  



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-23 02:50 UTC] zak at cvs dot php dot net
Please upgrade to the most recent release of PHP.
If the error still occurs, please submit a new bug report.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 24 02:03:34 2021 UTC