php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2730 for loop ignores fractions
Submitted: 1999-11-16 14:38 UTC Modified: 2001-02-10 15:48 UTC
From: kevin at dope dot de Assigned:
Status: Closed Package: Parser error
PHP Version: 3.0.12 OS: Linux 2.0.36
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: kevin at dope dot de
New email:
PHP Version: OS:

 

 [1999-11-16 14:38 UTC] kevin at dope dot de
When I use this script with my employer's computer (Linux 2.0.36, Apache 1.3.9, PHP 3.0.12, OCI8 and Oracle):

for ($i=0; $i<10; $i += .5) {
        echo $i . "<br>";
        }

I get an infinite loop, because $i remains zero. If I increment $i with 1.5 each time, it gets actually incremented with 1, so it seems like the increment is floor()'ed before.
The script runs perfectly on my workstation (Linux 2.2.13, Apache 1.3.4, PHP3.0.7, MySQL).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-16 15:27 UTC] kevin at dope dot de
It works if I use
1/2
instead of
.5
And there is no php.ini on either computer
 [2000-08-17 15:43 UTC] hholzgra@php.net
this is locale-dependant, it has been fixed for 
php4 but not php3

as a workaround use setlocale("C",LC_ALL)
 [2001-02-10 15:48 UTC] jimw@php.net
duplicate of 2260.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 09:01:28 2024 UTC