php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27273 Segfault in apache after rebuild with 5.0.0b4
Submitted: 2004-02-16 07:23 UTC Modified: 2004-02-16 15:16 UTC
From: chris at areti dot net Assigned:
Status: Closed Package: Apache related
PHP Version: 5.0.0b4 (beta4) OS: Slackware Linux 9.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chris at areti dot net
New email:
PHP Version: OS:

 

 [2004-02-16 07:23 UTC] chris at areti dot net
Description:
------------
An apache 1.3.29 build against php 5.0.0b3 ran fine, but I have now upgraded it to php 5.0.0b4 and apache segfaults on start up.

My configure line is:
./configure  --with-mysql=/usr/local/include/mysql --with-apache=../apache_1.3.29 --with-gd --with-pgsql=/usr/local/pgsql --with-zlib-dir=/usr/local/lib --enable-track-vars



Reproduce code:
---------------
N/A

Expected result:
----------------
Apache running correctly

Actual result:
--------------
(gdb) run -X
Starting program: /usr/local/apache/bin/httpd -X
(no debugging symbols found)...[New Thread 16384 (LWP 1978)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 1978)]
0x080b4573 in zend_do_inherit_interfaces ()
(gdb) bt
#0  0x080b4573 in zend_do_inherit_interfaces ()
#1  0x080b46a9 in zend_do_inheritance ()
#2  0x080c4471 in zend_register_internal_class_ex ()
#3  0x081276fb in spl_register_sub_class ()
#4  0x0812c3ec in zm_startup_spl_sxe ()
#5  0x08126f4c in zm_startup_spl ()
#6  0x080c3ac3 in zend_startup_module ()
#7  0x08099c59 in php_startup_extensions ()
#8  0x080e1962 in php_startup_internal_extensions ()
#9  0x0809a010 in php_module_startup ()
#10 0x080923c3 in ap_get_server_built ()
#11 0x080930f7 in ap_get_server_built ()
#12 0x081d6814 in ap_init_modules ()
#13 0x081e0b3b in ap_child_terminate ()
#14 0x081e13f9 in main ()
#15 0x40237d06 in __libc_start_main () from /lib/libc.so.6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-16 11:19 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2004-02-16 14:17 UTC] chris at areti dot net
Yep, with the latest snapshot apache runs fine.. :)

Thanks!
 [2004-02-16 15:16 UTC] sniper@php.net
Fixed -> closed.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 16:03:34 2022 UTC