php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27246 fastcgi segfaults on faulty pages
Submitted: 2004-02-13 15:52 UTC Modified: 2004-02-14 15:29 UTC
From: pmoor at netpeople dot ch Assigned:
Status: Closed Package: CGI/CLI related
PHP Version: 5.0.0b4 (beta4) OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pmoor at netpeople dot ch
New email:
PHP Version: OS:

 

 [2004-02-13 15:52 UTC] pmoor at netpeople dot ch
Description:
------------
When using php as a fastcgi application (with apache) it segfaults after reloading a page which contains php-errors two times.

reproduce:
 - create page which contains errors
 - load page in browser
 - refresh once
 - refresh twice
 -> segfault (500 internal server error)

log entry:
...terminated due to uncaught signal '11' (Segmentation fault)

the same config for fastcgi worked with v4.x
it also worked before (5.0.0RC1-dev).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-14 12:26 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2004-02-14 15:29 UTC] pmoor at netpeople dot ch
recompiled it and discovered problems with openssl libraries. (mysql libraries compiled with older ones than php). i disabled mysql and now it works like a charm.

sorry for bothering you...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 02:01:23 2021 UTC