php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27198 'Charset not found'-warning when using CGI
Submitted: 2004-02-09 16:43 UTC Modified: 2004-02-09 21:52 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (66.7%)
From: spam at eMeidi dot com Assigned:
Status: Wont fix Package: MySQL related
PHP Version: 4.3.5RC2 OS: Windows 2003
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: spam at eMeidi dot com
New email:
PHP Version: OS:

 

 [2004-02-09 16:43 UTC] spam at eMeidi dot com
Description:
------------
PHP doesn't parse C:\WINDOWS\my.ini, where charset informations would have been specified for the current webserver. Instead, it tries to locate them somewhere in C:\MySQL\ ... - seems to be hardcoded. It would make more sense to look after C:\WINDOWS\my.ini, and only afterwards trying to hit the charsets directly.

Output while running php.exe when having MySQL-function calls in PHP-Script:

File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2)
Character set '#5' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file

Reproduce code:
---------------
$res_db_conn = mysql_connect($arr_user_data[0],$arr_user_data[1],$arr_user_data[2]);

Expected result:
----------------
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2)
Character set '#5' is not a compiled character set and is not specified in the 'c:\mysql\share\charsets\Index' file

Except of this warning (and a disgusting beep), everything works out fine. Very bad when running cron-jobs ;-)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-09 21:52 UTC] sniper@php.net
In PHP 5 you can use your own libmysql.dll. 
The bundled mysql lib in PHP 4 will not be changed.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 16:03:35 2021 UTC