php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27025 4.3.3 Blank Page, Apache
Submitted: 2004-01-23 14:45 UTC Modified: 2004-01-28 21:08 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: vmelody at nd dot edu Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.3.4 OS: SunOS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vmelody at nd dot edu
New email:
PHP Version: OS:

 

 [2004-01-23 14:45 UTC] vmelody at nd dot edu
Description:
------------
I am currently seeing this exact same bug as referenced in PHP Bug 24666. 

Our website has been up and running for over 2 years now and we recently upgraded the webserver from 4.3.1 to php 4.3.3, Apache 1.3.29 and various other updates to the os etc.  The error described in bug report 24666 has occurred with any page with php code in it. I even created a page with just:

<?PHP
echo "THIS IS A TEST!";
?>

Even with just that simple of a page the error occurred. I have tried to force the bug with just a standard html page and I cannot which leads me to believe that this is a bug with php itself and not with apache or maybe it is a combination. 

We did testing before going live with Server2 and did not see this error.  So we took Server1(our live server) down and made our Server2 our live server.  After doing this we began to see this bug after a couple days. So we thought that it might be related to the load on Server2 and before we did alot of debugging we completed our upgrades Server1 (typically our live server).  However after making Server1 live again we continued to see this error. So our system admin has been doing some testing on Server2 to try to reproduce this error.  Even though no changes were made to server2, we now cannot reproduce the error. I have done the same on a test server in my office but I cannot reproduce the error while testing.


Below you will find some information from phpinfo command. If you have any thoughts on how to best trouble shoot this I would appreciate it. I have already download the latest version from snap.php.net but since it was assumed 4.3.3 fixed the problem and since it did not show up during our
orginal test, I am looking for thoughts on how best to hunt this bug down.

Thanks!
Vincent


SunOS www3 5.8 Generic_108528-27 sun4u

/configure' '--prefix=/local/www/php' 
'--with-apxs=/local/www/apache/bin/apxs' '--with-mysql=/local/www/mysql' 
'--with-openssl=/local/www/openssl' 
'--with-oci8=/local/orasoft/app/oracle/product/8.1.7' 
'--with-ldap=/local/www/ldap' '--with-yaz=/local/www/yaz' 
'--enable-xslt' '--with-xslt-sablot=/local/www/Sablot' 
'--enable-sablot-errors-descriptive' '--with-expat-dir=/local/www/expat' 
'--with-gd' '--with-jpeg-dir=/local/www/jpeg' 
'--with-zlib-dir=/local/www/zlib' '--with-png-dir=/local/www/png' 
'--with-exec-dir=/local/www/php/bin' 
'--with-config-file-path=/local/www/php' '--enable-thread-safety' 
'--enable-track-vars' '--enable-libgcc' '--enable-sigchild'

Apache/1.3.29
Apache Release 10329100

Loaded Modules
mod_php4, mod_nd, mod_ssl, mod_setenvif, mod_so, mod_proxy, mod_auth, 
mod_access, mod_rewrite, mod_alias, mod_userdir, mod_actions, mod_imap, 
mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_status, 
mod_negotiation, mod_mime, mod_log_config, mod_env, http_core





Reproduce code:
---------------
<?PHP
echo "THIS IS A TEST!";
?>

Expected result:
----------------
THIS IS A TEST!

Actual result:
--------------
<HTML><BODY></BODY></HTML>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-27 22:04 UTC] mike at ileadmedia dot com
I forgot to leave you with my entire configuration:

I installed Apache, PHP, and Mod Perl via the ports:
/usr/ports/www/apache13
/usr/ports/www/mod_perl
/usr/ports/www/mod_php4


FreeBSD 5.2
PHP Version 4.3.4
Apache Version 1.3.29

System: FreeBSD secure.secureinternetstores.com 5.2-RELEASE FreeBSD 5.2-RELEASE #0: Sun Jan 11 04:21:45 GMT 2004 root@wv1u.btc.adaptec.com:/usr/obj/usr/src/sys/GENERIC i386 

Build Date: Jan 16 2004 18:38:33 

Configure Command: './configure' '--enable-versioning' '--enable-memory-limit' '--with-layout=GNU' '--with-zlib-dir=/usr' '--disable-all' '--with-regex=php' '--disable-cli' '--enable-calendar' '--enable-ctype' '--with-curl=/usr/local' '--enable-dba' '--enable-ftp' '--with-gettext=/usr/local' '--with-inifile' '--with-mcrypt=/usr/local' '--with-mhash=/usr/local' '--with-mime-magic=/usr/share/misc/magic.mime' '--with-ming=/usr/local' '--with-mysql=/usr/local' '--with-ldap=/usr/local' '--with-openssl-dir=/usr' '--with-openssl=/usr' '--enable-overload' '--with-pcre-regex=yes' '--with-pdflib=/usr/local' '--enable-posix' '--with-pgsql=/usr/local' '--with-pspell=/usr/local' '--enable-session' '--enable-sockets' '--enable-tokenizer' '--with-expat-dir=/usr/local' '--enable-xml' '--with-zip=/usr/local' '--with-zlib=yes' '--with-apxs=/usr/local/sbin/apxs' '--with-imap=/usr/local' '--with-imap-ssl=/usr/local' '--with-snmp=/usr/local' '--enable-ucd-snmp-hack' '--prefix=/usr/local' 'i386-portbld-freebsd5.2' 

Thread Safety: disabled 
Debug Build: no
Zend Extension: 20021010 
PHP Extension: 20020429 
PHP API: 20020918 
Virtual Directory Support: disabled 
Server API: Apache

Do you need any other information?
 [2004-01-27 22:07 UTC] mike at ileadmedia dot com
Also, my output is different.   I get absolutely nothing when I view the source.  Not even a whitespace character.
 [2004-01-28 00:57 UTC] mike at ileadmedia dot com
I solved the issue.  Took me forever to figure it out.  I tried just about every relevant settings change in the php.ini file only to find that the error really was in the Apache configuration.

The error only occured on 128bit encryption compatible web browsers.  I had the SSL settings simplified down, so I started over with the httpd.conf-dist file and found that I was lacking a lot of settings for the SSL service.  Once I fixed that, the random blank screen totally went away.
 [2004-01-28 21:08 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

User error -> bogus

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 13:06:06 2022 UTC