php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2697 Compilation errors
Submitted: 1999-11-10 19:03 UTC Modified: 2002-10-01 10:27 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: Bernhard dot Bock at ThePentagon dot com Assigned:
Status: Wont fix Package: LDAP related
PHP Version: 3.0.12 OS: WinNT v4.0 SP5 (german)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Bernhard dot Bock at ThePentagon dot com
New email:
PHP Version: OS:

 

 [1999-11-10 19:03 UTC] Bernhard dot Bock at ThePentagon dot com
I have build the php3.0.12 from the source and the win32build.zip files.

The only file that cannot be build is the php3_ldap.dll because of the following errors:
C:\php-3.0.12\functions\ldap.c(607) : error C2037: left of 'ld_errno' specifies undefined struct/union 'ldap'
C:\php-3.0.12\functions\ldap.c(607) : error C2198: 'ldap_err2string' : too few actual parameters

Cause: the struct ldap is undefined. I guess there is an external lib/definition-file that is missing?

I have found the ldap-sdk at www.mozilla.org and will look inside it.
If you have any helpful suggestions, please let me know!

I use the MS VC++ v6.0 SP3 Enterprise Edition to compile this.

Greetings
Bernhard

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 10:27 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.  Momentum is
gathering for PHP 5, and we think supporting PHP 3 will lead to a waste of
resources which we want to put into getting PHP 5 ready. Ofcourse PHP 4 will
will continue to be supported for the forseeable future.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC