php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26851 Unable to find the wrapper "http"
Submitted: 2004-01-09 05:43 UTC Modified: 2004-01-13 11:33 UTC
From: info at sovall dot cz Assigned: pollita (profile)
Status: Closed Package: Filesystem function related
PHP Version: 5CVS-2004-01-09 (dev) OS: win2k
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at sovall dot cz
New email:
PHP Version: OS:

 

 [2004-01-09 05:43 UTC] info at sovall dot cz
Description:
------------
Unable to find the wrapper "http".

Reproduce code:
---------------
<?php
ini_set('allow_url_fopen', '1');
ini_set('user_agent', 'PHP');
$file = fopen ("http://www.php.net/", "r");
?>

Actual result:
--------------
Notice: fopen() [function.fopen]: Unable to find the wrapper "http" - did you forget to enable it when you configured PHP?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-09 11:34 UTC] pollita@php.net
allow_url_fopen is a PHP_SYSTEM value and cannot be changed in a script.

That shouldn't be responsible for your error though, could you run this code snippet and output the results?

<?php
  var_dump(stream_get_wrappers());
?>
 [2004-01-12 02:06 UTC] info at sovall dot cz
Code snippet output result:

array(3) {
  [0]=>
  string(3) "php"
  [1]=>
  string(4) "file"
  [2]=>
  string(13) "compress.zlib"
}

allow_url_fopen is set to On in php.ini.
 [2004-01-13 00:27 UTC] pollita@php.net
This seems to be related to the new Win32 build system.

Assigning to myself, but secretly looking for Wez in IRC.
 [2004-01-13 11:33 UTC] pollita@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 20:04:13 2023 UTC