php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26837 mhash seems not loading on PHP as ISAPI
Submitted: 2004-01-08 04:19 UTC Modified: 2004-01-08 06:30 UTC
From: webmaster at sparovcek dot net Assigned:
Status: Not a bug Package: mhash related
PHP Version: 4.3.4 OS: Win2k server/IIS5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: webmaster at sparovcek dot net
New email:
PHP Version: OS:

 

 [2004-01-08 04:19 UTC] webmaster at sparovcek dot net
Description:
------------
I was trying to install php_mhash.dll with bundled libmhash.dll library on my Windows 2000 server, but it simply did not start!
Everytime I called mhash() function, I get error:

"Call to undefined function mhash() ..."

After some exercise with checking /extensions dir, and PHP.INI, and after I found 0 (ZERO) configuration mistakes (all other extensions and modules loaded with no problem), I did the following:

I copied the PHP installation from server to my local machine, and installed it. And mhash() function WORKED WITH NO PROBLEM!

Now, where are the diferences?

MHASH is NOT WORKING on this machine:
- Windows 2000 server
- IIS 5
- PHP 4.3.4 loaded as ISAPI 

MHASH is WORKING on this machine:
- Windows XP pro
- Apache 1.3.23
- PHP 4.3.4 loaded as CGI/EXE

My opinion is that running PHP as ISAPI module has something to do with it. But I did not experiment too much, because I have only *working* server, not for development purposes.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-08 06:30 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

You were just doing something wrong...
 [2004-02-22 23:59 UTC] peter dot bates at lands dot nsw dot gov dot au
I had this issue myself.
Its not a bug with PHP, just a windows issue.

php_mhash.dll depends on another DLL, libmhash.dll
This is stored in D:\php\dlls\libmhash.dll, or wherever PHP is installed to.

The fastest way to get it working is copy libmhash.dll to your 
%SystemRoot%\system32 dir.

Same goes for quite a few extensions.

Hope this helps.

Peter Bates
Systems Administrator
NSW Department of Lands
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 17:01:23 2020 UTC