php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26795 signal Segmentation fault when calling domxml_open_file
Submitted: 2004-01-05 10:44 UTC Modified: 2004-01-06 16:39 UTC
From: oliver at lanifex dot com Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 4.3.4 OS: RedHat 7.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: oliver at lanifex dot com
New email:
PHP Version: OS:

 

 [2004-01-05 10:44 UTC] oliver at lanifex dot com
Description:
------------
When i execute this code with apache i get a signal Segmentation fault (11)
when i run it from command line it seems to work fine.

[PHP Modules]
ctype
curl
domxml
gd
gettext
mcrypt
mysql
openssl
overload
pcntl
pcre
pdf
posix
session
snmp
standard
tokenizer
xml
zlib

Apache/1.3.29 (Unix) PHP/4.3.4 mod_ssl/2.8.16 OpenSSL/0.9.6b mod_perl/1.27

libxslt-devel-1.0.32-1
libxml-devel-1.8.14-2
libxml2-devel-2.6.4-1



Reproduce code:
---------------
if(!$xmldoc = domxml_open_file($xml_config_file, DOMXML_LOAD_VALIDATING)) {
  exit("Error while parsing the document\n");
  exit;
}

Actual result:
--------------
#0  0x406b8000 in pdf_core_metrics () from /usr/local/lib/libpdf.so.1
#1  0x408abf34 in xmlGzfileOpen_real () from /usr/lib/libxml2.so.2
#2  0x408abf5d in xmlGzfileOpen () from /usr/lib/libxml2.so.2
#3  0x408ad1e8 in xmlParserInputBufferCreateFilename () from /usr/lib/libxml2.so.2
#4  0x4088901d in xmlNewInputFromFile () from /usr/lib/libxml2.so.2
#5  0x408ae3e3 in xmlDefaultExternalEntityLoader () from /usr/lib/libxml2.so.2
#6  0x408ae4d5 in xmlLoadExternalEntity () from /usr/lib/libxml2.so.2
#7  0x4089cf40 in xmlCreateURLParserCtxt () from /usr/lib/libxml2.so.2
#8  0x4089cfcd in xmlCreateFileParserCtxt () from /usr/lib/libxml2.so.2
#9  0x40334568 in zif_domxml_doc_ids () from /usr/local/apache_EH/libexec/libphp4.so
#10 0x40334a03 in zif_xmldocfile () from /usr/local/apache_EH/libexec/libphp4.so
#11 0x4047b96f in execute () from /usr/local/apache_EH/libexec/libphp4.so
#12 0x4047dbce in execute () from /usr/local/apache_EH/libexec/libphp4.so
#13 0x40469650 in zend_execute_scripts () from /usr/local/apache_EH/libexec/libphp4.so
#14 0x4043086a in php_execute_script () from /usr/local/apache_EH/libexec/libphp4.so
#15 0x40480b12 in apache_php_module_main () from /usr/local/apache_EH/libexec/libphp4.so
#16 0x40481b18 in apache_php_module_main () from /usr/local/apache_EH/libexec/libphp4.so
#17 0x40481b85 in apache_php_module_main () from /usr/local/apache_EH/libexec/libphp4.so
#18 0x0808a9d3 in ap_invoke_handler ()
#19 0x080a04a7 in ap_some_auth_required ()
#20 0x080a0915 in ap_internal_redirect ()
#21 0x08065ce8 in ap_get_server_built ()
#22 0x0808a9d3 in ap_invoke_handler ()
#23 0x080a04a7 in ap_some_auth_required ()
#24 0x080a0508 in ap_process_request ()
#25 0x08097185 in ap_child_terminate ()
#26 0x08097354 in ap_child_terminate ()
#27 0x080974c8 in ap_child_terminate ()
#28 0x08097bb8 in ap_child_terminate ()
#29 0x08098437 in main ()
#30 0x400bd657 in __libc_start_main (main=0x8098074 <main>, argc=2, ubp_av=0xbffffaa4, init=0x8050278 <_init>,
    fini=0x80b9000 <_fini>, rtld_fini=0x4000dc54 <_dl_fini>, stack_end=0xbffffa9c) at ../sysdeps/generic/libc-start.c:129


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-06 12:56 UTC] rrichards@php.net
Does it work when libxml is built without zlib support?
 [2004-01-06 13:06 UTC] oliver at lanifex dot com
Sorry for the miss leading info, i rebuild php on a fresh redhat install and it now works, seems that something else must be broken on the machine.
Thanks for the feed back any hows, sorry for thinking it was a php bug :-)
 [2004-01-06 16:39 UTC] magnus@php.net
Since it wasn't a bug in PHP, the status should be "Bogus".
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 14:01:23 2020 UTC