|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26709 PHP and Xitami Related to Bug #25305 "No input file specified." error
Submitted: 2003-12-24 10:19 UTC Modified: 2004-01-17 00:51 UTC
Avg. Score:4.8 ± 0.4
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:0 (0.0%)
From: sailorb at netvision dot net dot il Assigned:
Status: No Feedback Package: Other web server
PHP Version: 4.3.4 OS: Windows 2000 SP4
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: sailorb at netvision dot net dot il
New email:
PHP Version: OS:


 [2003-12-24 10:19 UTC] sailorb at netvision dot net dot il
"No input file specified." problem.

However, I am running Xitami v2.5b1 with PHP 4.3.4 on Win2k and I still recieve the error. In php.ini I have the following:

; doc_root =
cgi.force_redirect = 0
cgi.fix_pathinfo = 1

I think the issue is related to the fact that the default cgi-bin directory is seperated from the webpages directory i.e. c:\xitami\cgi-bin and c:\xitami\webpages?

Maybe changing Xitami settings so that cgi-bin will be under webpages will help (i.e. c:\xitami\webpages\cgi-bin)?

Reproduce code:
  <title>PHP Test</title>
    echo "Hello There<br>";
 <pre > 

Expected result:
Hello There

and the output of the two function calls.

Actual result:
No input file specified.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-17 00:51 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

 [2004-02-10 00:32 UTC] arcade at dotcomrefugee dot org
I have experienced a similar problem.  I first had PHP 4.3.4 and compiled a CGI version and a CLI version.  CLI works fine, and the CGI seems to work too.

But under thttpd 2.23beta1, I would get "No input file specified." when running hello world.  It's running on a Debian 2.4.24.

The PHP is as follows:
print "hello world.";

Permissions (according to thttpd) seem to be set correctly (chmod 755).

I then tried to download the latest CVS snapshot -- PHP 4.3.5RC2 (cgi) (built: Feb 10 2004 00:26:50).  Compiled the same way as before.  CGI version and a CLI version.

Same problem.  Something I'm doing incorrectly?  The above was probably not a very good bug report :(

 [2004-02-29 07:08 UTC] k dot weinert at gmx dot net
i have the same problem, but since it is my first try with php/xitami, it may be due to configuration errors.

- php-Version: 4.3.4, using the CVS-snapshot from 2003-11-03 mentioned above.
- xitami-Version: 2.5
- OS: Windows 98

How i installed it:

I installed Xitami via its installer in c:\xitami, extracted the php-zip-archive and copied php.exe and almost all dlls from the subdirectories (except for the dlls in the sapi-directory) in c:\xitami.

I added a defaults.cfg for xitami containing:
   .php=php.exe      # Pass *.php to PHP.EXE

and created a php.ini in c:\windows, which is equal to the distributed php.ini-recommened, except for the following options:

;doc_root =
extension_dir = "C:\xitami"
cgi.force_redirect = 0

Now I have put a simple php-file in 

print "<html>\n<body>\n";
print "Hello!";
print "<body>\n<html>\n";

and tried to load http://localhost/cgi-bin/php_test.php.
I received the same message as sailorb:

No input file specified. 

but i expected


or a 404-Error. I don't know what is going on here and would appreciate any help.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 01:01:28 2024 UTC