php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #26689 Input Filter is not implemented for RFC1867 filenames
Submitted: 2003-12-22 07:27 UTC Modified: 2022-04-07 16:02 UTC
From: sesser@php.net Assigned: ilutov (profile)
Status: Closed Package: Filter related
PHP Version: Next minor version OS: Any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
15 - 11 = ?
Subscribe to this entry?

 
 [2003-12-22 07:27 UTC] sesser@php.net
Description:
------------
The new input filter code does not cover user
supplied filenames for rfc1867 fileuploads.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-22 07:32 UTC] derick@php.net
Not a bug but a feature request. Assigning to myself.
 [2005-03-07 09:36 UTC] derick@php.net
Unassigning - I've no time (nor interested) in implementing this.
 [2016-12-30 18:54 UTC] cmb@php.net
-Package: Feature/Change Request +Package: Filter related
 [2019-07-15 00:12 UTC] girgias@php.net
-PHP Version: 5CVS-2003-12-22 (dev) +PHP Version: Next minor version
 [2022-04-07 16:02 UTC] ilutov@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: ilutov
 [2022-04-07 16:02 UTC] ilutov@php.net
There has been no action in this issue for a long time. If this is still desired feel free to create a new issue on GitHub.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 20 09:01:31 2024 UTC