|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26680 Build of MySQLi extension failed (SERVER_QUERY_NO_GOOD_INDEX_USED undeclared)
Submitted: 2003-12-20 15:58 UTC Modified: 2003-12-22 11:52 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: rabus at users dot sourceforge dot net Assigned: georg (profile)
Status: Closed Package: Compile Failure
PHP Version: 5CVS-2003-12-20 (dev) OS: Linux 2.4.22 (Fedora Core 1)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: rabus at users dot sourceforge dot net
New email:
PHP Version: OS:


 [2003-12-20 15:58 UTC] rabus at users dot sourceforge dot net
I tried to build the latest CVS snapshot of php 5 with MySQLi extension against MySQL 4.1.1-alpha.

Unfortunately, the build failed with the error messages below.

Reproduce code:
./configure --prefix=/usr --with-apxs2 --with-config-file-path=/etc --with-openssl --with-zlib --enable-bcmath --with-bz2 --enable-calendar --with-curl --with-curlwrappers --enable-dba --with-db4 --with-flatfile --enable-dbx --enable-dio --enable-ftp --with-recode --with-gd=/usr --with-mysql=/usr --with-mysqli=/usr/bin/mysql_config


Expected result:
I expect php to be compiled.

Actual result:
/bin/sh /root/src/php5-200312200030/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/mysqli/ -I/root/src/php5-200312200030/ext/mysqli/ -DPHP_ATOM_INC -I/root/src/php5-200312200030/include -I/root/src/php5-200312200030/main -I/root/src/php5-200312200030 -I/root/src/php5-200312200030/Zend -I/usr/include/libxml2 -I/usr/include/mysql  -I/root/src/php5-200312200030/TSRM  -g -O2  -prefer-pic -c /root/src/php5-200312200030/ext/mysqli/mysqli_report.c -o ext/mysqli/mysqli_report.lo
/root/src/php5-200312200030/ext/mysqli/mysqli_report.c: In function `php_mysqli_report_index':
/root/src/php5-200312200030/ext/mysqli/mysqli_report.c:64: error: `SERVER_QUERY_NO_GOOD_INDEX_USED' undeclared (first use in this function)
/root/src/php5-200312200030/ext/mysqli/mysqli_report.c:64: error: (Each undeclared identifier is reported only once
/root/src/php5-200312200030/ext/mysqli/mysqli_report.c:64: error: for each function it appears in.)
/root/src/php5-200312200030/ext/mysqli/mysqli_report.c:66: error: `SERVER_QUERY_NO_INDEX_USED' undeclared (first use in this function)
make: *** [ext/mysqli/mysqli_report.lo] Error 1


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-20 17:06 UTC] rabus at users dot sourceforge dot net
I just tried the same with the official beta 2 release and it worked fine.
 [2003-12-22 11:52 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 10:01:34 2024 UTC