|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26618 Using <% %> tags makes include() not to work (sometimes)
Submitted: 2003-12-14 10:46 UTC Modified: 2004-02-22 18:28 UTC
From: t dot steve at ariadne-quatra dot com Assigned:
Status: No Feedback Package: IIS related
PHP Version: 5CVS-2003-12-14 OS: Windows 2000 server SP4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: t dot steve at ariadne-quatra dot com
New email:
PHP Version: OS:


 [2003-12-14 10:46 UTC] t dot steve at ariadne-quatra dot com
PHP5 beta2
Windows 2000 SP4
ISAPI mode

- Worked correctly with PHP4.3.4 with Zend 2.0.1

- With PHP5 beta2 (also ISAPI mode) a simple PHP page which uses include_once([local path]) to include the menu part of a web page sometimes works, sometimes does not (sometimes the menu is included, sometimes it is not). (There is only the single include_once in the code, so this is NOT an issue of my trying to include something twice with include_ONCE... )

- The page contains NO other PHP code, just the lines below:
<% include_once("c:/wwwroot/"); %>

( is the file to be included, it contains only html code, no php)

- Again, note that the exact same page, exact same setup works fine under 4.3.4 - and has done so with previous versions!

- Under PHP5, with every refresh of the page the inclusion of the file is erratic - every few refreshes the inclusion is not done.

If you need any part of my php.ini, let me know please.


Reproduce code:
<title>The world of services</title>

<% include_once("c:/wwwroot/"); %>

Please select from the menu on the left!


Expected result:
A page with the menu on the left (created fromt he included file), plus the contents.

Actual result:
Only the contents apperas, the inclusion is not done.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-16 02:48 UTC]
Try using the PHP tags, not those ugly ASP tags.
(<% %> -> <?php ?>)

 [2003-12-16 03:04 UTC] t dot steve at ariadne-quatra dot com
YES, with conventional <?php ?> tags the includes work perfectly and consistently! :)

However, this IS still a problem - I need to use the <% %> because of the editor I must use (FP...)! ASP-style tags ARE - in theory - supported, aren't they? (They are enabled in the INI file, and I have been using them in all our sites for ages without any problems!)

So then the problem changes to ASP-style <% %> tags versus regular <?php ?> tags... Do I have to open a new bug report, or just leave this one open?

 [2004-01-03 16:37 UTC] t dot steve at ariadne-quatra dot com
Another note: This cannot be an IIS related bug, it must be related to PHP itself since all previous versions of PHP worked fine even with the ASP delimiters (<% %>) which I have to use. The problem arose only as of version 5.x - including the latest build which I just tested.
 [2004-02-17 17:40 UTC]
Please try using this CVS snapshot:
For Windows:

There's good chance this is fixed now, can you please try the snapshot..

 [2004-02-22 18:28 UTC]
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 03:01:28 2024 UTC