php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #26575 Case Sensitive Class Names
Submitted: 2003-12-10 01:56 UTC Modified: 2005-05-02 11:28 UTC
Votes:408
Avg. Score:5.0 ± 0.0
Reproduced:9 of 9 (100.0%)
Same Version:3 (33.3%)
Same OS:5 (55.6%)
From: sbrendtro at comcast dot net Assigned:
Status: Wont fix Package: Feature/Change Request
PHP Version: 5CVS-2003-12-10 (dev) OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sbrendtro at comcast dot net
New email:
PHP Version: OS:

 

 [2003-12-10 01:56 UTC] sbrendtro at comcast dot net
Description:
------------
Since PHP more tightly integrating with Java in PHP5, it would be very benneficial if class names could be stored as case sensitive, or at least an option was available in php.ini. It seems strange that some things are case sensitive in PHP, while other things are not.  It would be easier to follow if everything were case sensitive... function names, variable names, class names, etc.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-02 11:28 UTC] andrey@php.net
This is "Won't fix". This will break enourmous number of applications. Still in PHP 5 one get the name used when declaring the class whenever needed. Look at serialization ot get_class_name() incompatibility of PHP 5 with PHP 4.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 01:01:23 2020 UTC