|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26558 High load of OCI-Calls crash on multiprocessor machine with Apache2
Submitted: 2003-12-09 04:38 UTC Modified: 2003-12-16 10:55 UTC
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: k_becker at kat dot de Assigned: tony2001 (profile)
Status: Closed Package: OCI8 related
PHP Version: 4.3.4 OS: Windows 2000 Adv. Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: k_becker at kat dot de
New email:
PHP Version: OS:


 [2003-12-09 04:38 UTC] k_becker at kat dot de
Platform: 4-CPU machine, Apache 2.0.39..48, PHP 4.3.x, Win 2000 Adv. server engl., OCI8, Oracle 8.1.7EE

When issuing multiple Oracle-requests at once, the Apache client thread dies with protection fault (C0000005) without any further message from PHP, Oracle or Apache.

Same code runs okay on one-CPU machine with same platform. Changing Apache to 1.3.28 helped.

Could be a problem within the PHP for Apache2 parallelization on more than one CPU.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-10 05:56 UTC] k_becker at kat dot de
I tried the "MaxThreadsPerChild=1" from Bug#19517. No crashes, but Apache "... ran out of threads".

Then set 
MaxRequestsPerChild 100000,
ThreadsPerChild 100
and tried using the explicit Oracle address string from TNSnames.ora. This seems to work.

Then tried of 2003-dec-10: Same result.

I now have: Apache/1.3.28 (Win32) PHP/4.3.5-dev, OCI8 Revision: on Windows 2000 adv. server build 2195 with MaxRequestsPerChild 100000, ThreadsPerChild 100.

Temporary solution seems to be using the TNS address string in OCILogon("user", "pass", "(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=")

So, problem seems to be in the Oracle/Oci8 name resolving in concurrent OCILogon()'s from multiple Apache/PHP-threads.
 [2003-12-10 09:19 UTC]
it seems to me, this bug appears due to the fact, that current implementation of ext/oci8 doesn't use OCI_THREADED flag with OCIInitialize();

Maxim tells about it here:

OCI docs about OCI's thread safety are here:

I think, I can add this feature shortly.
 [2003-12-16 10:55 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

should be fixed in CVS.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 18:01:30 2024 UTC