php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26537 Unable to run PHP5 when web-server started as a NT service
Submitted: 2003-12-06 04:49 UTC Modified: 2003-12-26 06:45 UTC
From: andrey at cherezov dot koenig dot su Assigned:
Status: Closed Package: CGI/CLI related
PHP Version: 5.0.0b2 (beta2) OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andrey at cherezov dot koenig dot su
New email:
PHP Version: OS:

 

 [2003-12-06 04:49 UTC] andrey at cherezov dot koenig dot su
Description:
------------
When I run php5.exe as a CGI from a web-server running as ordinal program (not a service) - php5 works perfect. If I start the same web-server as NT service and run CGI (php5.exe) with the same parameters again - php5.exe did not produce any output at all, just finished.

php4.exe (any version) works OK in this web-server both in service mode and ordinal app mode.

Reproduce code:
---------------
PhpInfo();

Expected result:
----------------
PHP Version 5.0.0b2 
System  Windows NT CHEREZOV 5.1 build 2600  
Build Date  Oct 30 2003 12:34:01  
Server API  CGI/FastCGI  
Virtual Directory Support  enabled  
Configuration File (php.ini) Path  G:\WINXP\php.ini  
PHP API  20030820  
PHP Extension  20020429  
Zend Extension  90021012  
Debug Build  no  
Thread Safety  enabled  
Registered PHP Streams  php, file, http, ftp, compress.zlib  
...
(This text displayed if I run php5.exe from NON service web-server).



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-06 20:09 UTC] andrey at cherezov dot koenig dot su
This web-server is acWEB (acWEB.sourceforge.net). It can run as NT service or as user-level application (when started as acWEB.exe, not from services control panel and not "net start acWEB"). PHP4 (and PHP3 too) works under acWEB in both modes - service and non-service. When I change association of *.php files from PHP4.exe to PHP5.exe in the acWEB config - PHP5 works right only in non-service mode; but when I start acWEB as a NT service - PHP5.exe did not produce any output to the acWEB CGI pipe.
 [2003-12-26 06:45 UTC] andrey at cherezov dot koenig dot su
In the PHP Version 5.0.0b3 this problem is solved. Thank you!
 [2013-05-22 14:18 UTC] katharina dot harlow at aol dot com
We're a group of volunteers and opening a new scheme in our community. Your website provided us with valuable info to work on. You have done a formidable job and our entire community will be thankful to you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Aug 04 06:01:24 2021 UTC