php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26455 Mass EXIT Signal Segmentation Fault
Submitted: 2003-11-28 17:07 UTC Modified: 2003-11-29 00:38 UTC
From: tim at hitcho dot com dot au Assigned:
Status: Closed Package: Apache related
PHP Version: 4.3.4 OS: FreeBSD 4.8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tim at hitcho dot com dot au
New email:
PHP Version: OS:

 

 [2003-11-28 17:07 UTC] tim at hitcho dot com dot au
Description:
------------
All pages are being served perfectly and PHP is working 
as designed but when Apache goes under heavy load and 
then Apache cleans up threads we get seg (11) for each 
thread in error logs.

I have tested with PHP with limited moduels compiled in 
etc and without change.

The only change is without PHP installed as a module I 
don't get any segs then.

It seems to be the same as:

Bug?#5168
exit signal Segmentation fault

But I have the lattest of all ports installed daily 
cvsupd.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-28 17:33 UTC] iliaa@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2003-11-28 19:45 UTC] iliaa@php.net
Please compile your php with --enable-debug and try to generate the backtrace once more.
 [2003-11-29 00:38 UTC] tim at hitcho dot com dot au
Seems to be related to PHP and Turck-MMCache 2.4.6
 [2004-01-15 12:18 UTC] next74 at yahoo dot com
I have FreeBSD 4.9p1 with Apache 1.3.29, PHP 4.3.4 and 
Turck MM Cache 2.4.6 and does the same:

child pid nnnn exit signal Segmentation fault (11)

Even with no pages served.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jun 28 19:05:44 2022 UTC