php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26444 magic_quotes turned on at random
Submitted: 2003-11-28 03:34 UTC Modified: 2003-11-28 07:52 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: joris at ideeel dot nl Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: Irrelevant OS: RH73
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joris at ideeel dot nl
New email:
PHP Version: OS:

 

 [2003-11-28 03:34 UTC] joris at ideeel dot nl
Description:
------------
Using PHP4.1.2-7.3.6 (standard RH73). 
Magic_quotes seems to turn on at random, displaying \" in the output instead of ". Reloading the page switches this behaviour between correct and wrong output at random. There is no pattern and sometimes the problem does not appear for hours. Restarting httpd sets PHP pages back to correct output for about 1 hour. We experience the problem with PHPsysinfo and PHPNuke, but not with PHPmyadmin, Squirrelmail or phpBB. I've recompiled PHP without enable_magic_quotes but this does not help. I've added a check for the setting of the magic_quotes variable but this always returns 0, even though slashed quotes are present in the page. PHPinfo can be viewed on http://eenvoortwee.nl/. 
Upgrading to PHP4.2+ is not really an option unless absolutely necessary (production machine). PHPsysinfo output can be viewed on http://eenvoortwee.nl/si/


Reproduce code:
---------------
http://eenvoortwee.nl/si/
as mentioned; the problem is displayed at random and my not be visible every time.

Expected result:
----------------
SNIP
<td width="15" height="15" 
SNIP

Actual result:
--------------
SNIP
<td width=\"15\" height=\"15\" 
SNIP

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-28 05:28 UTC] joris at ideeel dot nl
Bug HTML output at: http://eenvoortwee.nl/php_wrong.html
Picture at: http://eenvoortwee.nl/php-bug.jpg
Notice that the bar graph pictures do load correctly
 [2003-11-28 07:52 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #25753
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 21:05:52 2022 UTC