php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26442 eregi failed for ?[ mark
Submitted: 2003-11-28 02:12 UTC Modified: 2003-11-28 07:56 UTC
From: hsutanto78 at hotmail dot com Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 4.3.3 OS: WinXP Japanese
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hsutanto78 at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-11-28 02:12 UTC] hsutanto78 at hotmail dot com
Description:
------------
i've tried using both mb_eregi and eregi, both give error result. is it a bug?

Reproduce code:
---------------
if(eregi("?[","?R?[?h")) echo "MATCH!";

Expected result:
----------------
MATCH!

Actual result:
--------------
Warning: eregi(): REG_EBRACK: in C:\Inetpub\wwwroot\modules.php on line 99


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-28 07:56 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You need to escape special characters such as [ to get your regex to work properly.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 23:03:39 2021 UTC