php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26388 Unable to compile php-gtk on Slackware
Submitted: 2003-11-24 16:05 UTC Modified: 2003-12-01 10:11 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: dbellizz at angmar dot com Assigned:
Status: Wont fix Package: PHP-GTK related
PHP Version: Irrelevant OS: Slackware 9.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dbellizz at angmar dot com
New email:
PHP Version: OS:

 

 [2003-11-24 16:05 UTC] dbellizz at angmar dot com
Description:
------------
root@loki:/usr/local/src/php-gtk-1.0.0# ./buildconf
Configuring for:
  PHP Api Version:   20020918
  Zend Module Api No:   20020429
  Zend Extension Api No:   20021010
rebuilding configure
root@loki:/usr/local/src/php-gtk-1.0.0# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/Zend -I/usr/local/include/php/TSRM
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20020429
checking for re2c... exit 0;
checking for gawk... gawk
checking for PHP-GTK support... yes, shared
checking for gawk... (cached) gawk
checking for PHP executable in /usr/local/bin... found
./configure: line 2916: syntax error near unexpected token `debug,'
./configure: line 2916: `PHP_GTK_ARG_ENABLE(debug, whether to include debugging symbols,'
root@loki:/usr/local/src/php-gtk-1.0.0#


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-25 01:23 UTC] alan_k@php.net
plase check you have the specified versions of autoconf, automake, libtool etc. as specified in the manual.
 [2003-11-25 08:13 UTC] dbellizz at angmar dot com
automake (GNU automake) 1.7.8
ltmain.sh (GNU libtool) 1.4.3 (1.922.2.110 2002/10/23 01:39:54)
autoconf (GNU Autoconf) 2.57
 [2003-11-25 08:42 UTC] alan_k@php.net
From

http://gtk.php.net/manual/en/installunix.php


"libtool, automake and autoconf. The combination of libtool 1.4.2, automake 1.4 and autoconf 2.13 is known to work; mileage may vary with other version combinations."

I think (from memory) the biggest issue is probably autoconf - I dont think we've ever managed to get 2.57 to work.


 [2003-12-01 03:13 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-12-01 09:12 UTC] dbellizz at angmar dot com
Sigh what do you want me to say. Your software doesn't work with newer versions of autoconf. To me thats a bug which is  still valid but I get the impression that your not going to make any effort to fix this or offer a workaround. I guess I really didn't need to the use the app that required php-gtk anyway. Walks away bummed.
 [2003-12-01 10:11 UTC] alan_k@php.net
It will probably be fixed in GTK2, unless someone who knows autoconf/build system jumps forwards and offers a fix.


 [2003-12-09 10:16 UTC] k dot dambekalns at fishfarm dot de
This comment from http://gtk.php.net/manual/en/installunix.php helps (autoconf 2.58 used):
 ---- snip ----
Simple solution to PHP_GTK_ARG_ENABLE problem detailed below. This must be added to this page and the README, please oh please!

./buildconf
aclocal
./buildconf (again!)
./configure
make
make install

I also needed to make the following change to my php.ini:
extension_dir = /usr/local/lib/php/extensions/no-debug-non-zts-20020429/

Once that was in place, the tests ran beautifully!
 ---- snip ----

Karsten
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 21:01:23 2020 UTC