php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26221 Configure with imap-support broken
Submitted: 2003-11-12 10:29 UTC Modified: 2003-11-18 15:22 UTC
From: admin at sportsandbytes dot de Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.3.4 OS: Linux, RedHat 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: admin at sportsandbytes dot de
New email:
PHP Version: OS:

 

 [2003-11-12 10:29 UTC] admin at sportsandbytes dot de
Description:
------------
Hi,

the following Configure-Options work with php-4.3.3 but not with php-4.3.4:
./configure \
--with-apxs=/usr/local/apache/current/bin/apxs \
--with-zlib \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--enable-ftp \
--with-gd \
--enable-versioning \
--enable-track-vars=yes \
--enable-url-includes \
--enable-sysvshm=yes \
--enable-sysvsem=yes \
--with-config-file-path=/etc \
--with-freetype-dir=/usr/lib \
--enable-fastcgi \
--enable-debug \
--disable-ipv6 \
--with-openssl=/usr/local/openssl/current/ \
--with-imap \
--with-imap-ssl=/usr/local/openssl/current/ \
--with-kerberos

The Configure-Script ends with this:

...
...
...
checking whether to enable dbx support... no
checking whether to enable direct I/O support... no
checking for DOM support... no
checking for DOM XSLT support... no
checking for DOM EXSLT support... no
checking whether to enable EXIF (metadata from images) support... no
checking for FrontBase SQL92 (fbsql) support... no
checking for FDF support... no
checking whether to enable the bundled filePro support... no
checking for FriBidi support... no
checking whether to enable FTP support... yes
checking for GD support... yes
checking for the location of libjpeg... /usr/lib
checking for the location of libpng... /usr/lib
checking for the location of libXpm... no
checking for FreeType 1.x support... no
checking for FreeType 2... /usr/lib
checking for T1lib support... no
checking whether to enable truetype string function in GD... no
checking whether to enable JIS-mapped Japanese font support in GD... no
checking for fabsf... yes
checking for floorf... yes
checking for jpeg_read_header in -ljpeg... yes
checking for png_write_image in -lpng... yes
If configure fails try --with-xpm-dir=<DIR>
checking for GNU gettext support... no
checking for GNU MP support... no
checking for hwapi support... no
checking for Hyperwave support... no
checking for iconv support... no
checking for IMAP support... yes
checking for pam_start in -lpam... yes
checking for crypt in -lcrypt... yes
configure: error: Cannot find imap library (libc-client.a). Please check your IMAP installation.


The file is located here:
[root@mail src]# locate libc-client.a
/usr/lib/libc-client.a
[root@mail src]# cd /usr/lib
[root@mail lib]# ls -al | grep c-client
-rw-r--r--    1 root     root      2404414 Apr 18  2002 c-client.a
lrwxrwxrwx    1 root     root           10 Jun  3 14:29 libc-client.a -> c-client.a
[root@mail lib]# 

Without the imap-configure-options, configure and make work without a failure!

The other Software:

apache_1.3.29 at /usr/local/apache/current
openssl-0.9.7c at /usr/local/openssl/current
courier-imap-2.1.2 at /usr/local/courier-imap/current





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-18 15:22 UTC] sniper@php.net
Check the config.log for the reason why this fails.
This works just fine when your libraries and headers are correctly installed and you use the correct configure options.

Ask further support questions on the mailing lists.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 05:03:36 2022 UTC