php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26195 Not Using Remote Paths
Submitted: 2003-11-10 23:32 UTC Modified: 2003-11-11 16:27 UTC
From: bijan at tehranto dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.0.0b2 (beta2) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bijan at tehranto dot com
New email:
PHP Version: OS:

 

 [2003-11-10 23:32 UTC] bijan at tehranto dot com
Description:
------------
When using either imageSX or imageSY or imageCreateFromJpeg and etc.  The compiler does not allow imageSX('myimg.php?index=10') (Note: The file does exist and it is in the correct path)

Reproduce code:
---------------
for($i = 1; $i <= mysql_num_rows($result) ; $i++) {

$record = mysql_fetch_row($result);
$pics[$i]['src'] = "pg_im_full_by_id.php?ind=".$record[0];
			
$newIMG = imagecreatefromjpeg('pg_im_full_by_id.php?ind='.$record[0]);

$pics[$i]['width'] = imageSX($newIMG);
$pics[$i]['height'] = imageSY($newIMG);

}


Expected result:
----------------
Create an image using the source file, take its attributes and assign to the array.

Actual result:
--------------
Warning: imagesx(): supplied argument is not a valid Image resource

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-11 16:27 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

This is a support issue and not a bug.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 08:01:25 2020 UTC