php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26169 Search javascript Obfuscated
Submitted: 2003-11-07 18:39 UTC Modified: 2003-11-15 08:26 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: me at here dot com Assigned:
Status: Closed Package: Website problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: me at here dot com
New email:
PHP Version: OS:

 

 [2003-11-07 18:39 UTC] me at here dot com
Description:
------------
http://static.php.net/www.php.net/functions.js is obfuscated and impossible for humans to read.

Expected result:
----------------
The code should be unobfuscated

Actual result:
--------------
Code is obfuscated

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-07 18:52 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Nothing wrong here.
 [2003-11-13 23:13 UTC] e1-wjj8-6zrw-tw73 at emailias dot com
Hello,

it would be nice to see the unobfuscated code in order to figure out how it works.

Is there a logical reason for keeping it obfuscated (copyright / patent / paranoia ) ?

Thanks
 [2003-11-14 01:30 UTC] derick@php.net
It's because of performance reasons. 
 [2003-11-14 03:14 UTC] didou@php.net
I'll add some infos about the compression method on the search.php page.
 [2003-11-15 08:26 UTC] didou@php.net
Gabor did my homework :) you can know see the uncompressed source in functions.js.txt
 [2004-04-07 08:43 UTC] phplover at hotmail dot com
Where can I find this file ??
functions.js.txt
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 21 13:01:27 2024 UTC