php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26161 apache2 "can not" load libphp4.so
Submitted: 2003-11-07 03:58 UTC Modified: 2003-11-17 18:10 UTC
From: artistoex at yahoo dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.3 OS: Debian/unstable
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: artistoex at yahoo dot com
New email:
PHP Version: OS:

 

 [2003-11-07 03:58 UTC] artistoex at yahoo dot com
Description:
------------
- i compiled php:
   ./configure --with-apxs2=/usr/bin/apxs2 --with-mysql

- apache2 says he could not load libphp4.so into server:

Syntax error on line 390 of /etc/apache2/apache2.conf:
Cannot load /usr/lib/apache2/modules/libphp4.so into server: /usr/lib/apache2/modules/libphp4.so: undefined symbol: core_globals_id
- i am using latest versions of both apache2 and php and the bug still exists (so is it a php or actually an apache2 bug???)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-10 20:09 UTC] iliaa@php.net
Did you compile Apache 2 for thread or fork based model?
 [2003-11-11 19:09 UTC] artistoex at yahoo dot com
As I haven't compiled apache on my own I don't know that.
Is there any way to determine that? I installed the apache package which is brought with Debian/unstable.
 [2003-11-17 18:10 UTC] sniper@php.net
Then install PHP also from such a package.

 [2004-01-20 13:13 UTC] mandl dot t at ikarus dot at
I ran into the same problem when compiling php-4.3.4 on a RedHat 8.0 system with apache 2.0.48, mod_perl-1.99_12

Here's my apache2 configure commandline 
./configure --prefix=/usr/local/apache2 --enable-layout=Apache --enable-so --enable-module=access --enable-module=log_config --enable-module=mime --enable-module=auth --disable-auth-anon --enable-auth_dbm --enable-auth-digest --disable-example --enable-deflate --enable-log-config --enable-logio --enable-expires --enable-headers --enable-usertrack --enable-ssl --enable-cgi --enable-cgid --enable-http --enable-rewrite --enable-http --enable-static-support --enable-static-htpasswd --enable-static-htdigest --enable-static-rotatelogs --enable-static-logresolve --enable-static-htdbm --enable-static-ab --enable-static-checkgid --with-mpm=prefork

Note: mod_perl says one should compile apache with mpm=prefork

Detailed error message from php-4.3.4 make test:
Syntax error on line 231 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3: undefined symbol: _Unwind_GetIP

Any help is appreciated.
Thanks
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 13:01:28 2024 UTC