php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25991 bugs: bring back the "all bug types" search option
Submitted: 2003-10-26 07:04 UTC Modified: 2005-09-05 12:06 UTC
Votes:4
Avg. Score:4.0 ± 1.0
Reproduced:1 of 3 (33.3%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: hetta at spamcop dot net Assigned:
Status: Wont fix Package: Website problem
PHP Version: 4.3.3 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hetta at spamcop dot net
New email:
PHP Version: OS:

 

 [2003-10-26 07:04 UTC] hetta at spamcop dot net
Description:
------------
Trying to find bugs with iptcembed() in bug tracking software

Reproduce code:
---------------
On this page:
http://bugs.php.net/
http://bugs.php.net/search.php
search term: "iptcembed" (quotes or no, no difference; on the advanced search page, status open or all, no difference.)
 ditto  "fotoware"
 ditto  "FotoWare"
 ditto  "FotoWare iptcembed"


Expected result:
----------------
All bugs, any status, for the search term.

For instance, bug # 15662, which details how the current industry standard, Adobe Photoshop, will NOT work with iptcembed() -enhanced images. This because Photoshop uses FotoWare for its iptc tags.

That's pretty much a complete showstopper for iptcembed() right there.

In addition I'd like to know if there are any other issues with iptcembed() which would mean that I should give up all hope of ever using it.

(Perhaps iptcembed() would actually be used if it worked? The _concept_ is immensely useful, the manual info is not, and the googlegroups search results are particularly discouraging.)


Actual result:
--------------
One single bug, closed, in return: 14257.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-25 19:43 UTC] philip@php.net
This is because bug #15662 is a feature request and according to the source one cannot search all bug types including feature requests (this was an undocumented change), here's that source:

    if (count($bug_type) == 0) {
        $where_clause = "WHERE bug_type != 'Feature/Change Request'";
    } else {
        $where_clause = "WHERE bug_type IN ('" . join("','", $bug_type) . "')";
    }

I think there should be an option to search ALL types including feature requests (like there used to be) and until that's resolved (either make it possible or document this behavior) this bug report should remain open.

Having to manually select every category seems too difficult/hackish.
 [2005-09-05 12:06 UTC] sniper@php.net
Won't change.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Mar 19 21:01:27 2019 UTC