php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25990 ob_get_clean () does not execute a callback function registered in ob_start ()
Submitted: 2003-10-26 04:15 UTC Modified: 2003-10-26 12:37 UTC
From: MDonatas at centras dot lt Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.3.3 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: MDonatas at centras dot lt
New email:
PHP Version: OS:

 

 [2003-10-26 04:15 UTC] MDonatas at centras dot lt
Description:
------------
in manaul it says
[QUOTE]
ob_get_clean() essentially executes both ob_get_contents() and ob_end_clean().
[/QUOTE]

ob_end_clean() alone does call a registered callback function.

Expected result:
----------------
callback function registered in ob_start () to get called by ob_get_clean ()

Actual result:
--------------
It does not

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-26 12:37 UTC] helly@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

See #25988
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 20 18:05:43 2022 UTC