php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2588 get_meta_tags() dropping chars?
Submitted: 1999-10-22 10:32 UTC Modified: 2002-06-16 14:17 UTC
From: datorrey at yahoo dot com Assigned:
Status: Not a bug Package: Misbehaving function
PHP Version: 3.0.12 OS: Digital Unix 4.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: datorrey at yahoo dot com
New email:
PHP Version: OS:

 

 [1999-10-22 10:32 UTC] datorrey at yahoo dot com
On Digital Unix 4.0D, get_meta_tags() returns the tag name minus the first character.  A meta tag that looks like

  <meta name="123435" content="foo">

ends up as "2345" => "foo" in the array that get_meta_tags() stores its results in.

Adding a space to the beginning of the tag name:

  <meta name=" 123435" content="foo">

produces "_2345" => "foo".

The content of the tag is unaffected, only the name gets munged.

Build info:

./configure --prefix=/opt/php3 --with-apache=../apache_1.3.9 --enable-track -vars --with-config-file-path=/opt/php3

gcc version 2.8.1

Hope this is useful...

-daniel


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 14:17 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Sep 15 10:01:26 2019 UTC