php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25823 stack trace error on java when executing
Submitted: 2003-10-10 12:30 UTC Modified: 2003-10-12 23:14 UTC
From: wewing at nc dot rr dot com Assigned:
Status: Not a bug Package: Servlet related
PHP Version: 4.3.4RC1 OS: Win2k
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wewing at nc dot rr dot com
New email:
PHP Version: OS:

 

 [2003-10-10 12:30 UTC] wewing at nc dot rr dot com
Description:
------------
I installed php 4.3.4RC1 on a tomcat 4.1 server with jdk 1.4.1, then I created a simple script page <? phpinfo(); ?>  When I call the page the first time, I see the phpinfo returned.  Then when I hit refresh or try to hit the page a second time, my tomcat server window abends and disappears.  I must have php configured correctly, or I wouldn't have received the phpinfo back, and the server window goes away, so I can't read the stack trace. Nothing shows up in my tomcat log, but I may not have logging set to show all items possible.  One other item, when I hit the page the first time, right before I get the phpinfo back, I get 3 warning messages:

Function registration failed - duplicate name - java_last_exception_get

Function registration failed - duplicate name - 
java_last_exception_clear

java: Unable to register functions, unable to load

Essentially my configuration was simple, copy the files to d:\php, then make sure d:\php;d:\php\dlls;d:\php\sapi;d:\php\extensions were in my path, then copy the php.ini to the winnt directory, and edit it so that the php_java.dll extension was enabled.  Then I copied the phpsrvlt.jar to the d:\tomcat\conf\lib and put the appropriate servlet tags into the d:\tomcat\conf\web.xml


Reproduce code:
---------------
<? phpinfo(); ?>

Expected result:
----------------
the page shouldn't abend the server on its second access


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-12 23:14 UTC] sniper@php.net
See bug #16331

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 04:01:27 2020 UTC