php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25822 ftp_put of small files fails
Submitted: 2003-10-10 12:11 UTC Modified: 2003-11-14 08:58 UTC
From: jzimmerman at bmslab dot com Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.3.3 OS: windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jzimmerman at bmslab dot com
New email:
PHP Version: OS:

 

 [2003-10-10 12:11 UTC] jzimmerman at bmslab dot com
Description:
------------
I'm encountering a problem when issuing an ftp_put on small files. If a file is under about 8K, the put will fail with the following error message:

Warning: ftp_put(): Connection closed; transfer aborted

In isolating the failure, I was able to take the text file being ftp'd and remove one line at a time. The ftp worked until the file became smaller than about 8K.

The failure occurred in both ASCII and BINARY modes.

The destination FTP server in this case is the PABLO FTP server.

Thanks very much for your help,

John Zimmerman

Reproduce code:
---------------
$bUpload = ftp_put($connID, "myTest01.txt", "c:/public/transfer/intranet/myTest.txt", FTP_BINARY);

Expected result:
----------------
successful ftp transfer

Actual result:
--------------
Warning: ftp_put(): Connection closed; transfer aborted

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-12 23:17 UTC] sniper@php.net
I can't reproduce with other FTP servers.
Apprently some bug in that Pablo FTP server.

 [2003-11-14 08:58 UTC] jzimmerman at bmslab dot com
I should have tried it on different ftp servers before submitting. Thanks for looking into it. 

- John Zimmerman
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jan 26 09:03:33 2022 UTC