php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #25795 Adding option for turning out realm mangling in safe mode.
Submitted: 2003-10-08 10:43 UTC Modified: 2010-11-18 23:39 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: kubacki at uwth dot uni-hannover dot de Assigned:
Status: Wont fix Package: Safe Mode/open_basedir
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kubacki at uwth dot uni-hannover dot de
New email:
PHP Version: OS:

 

 [2003-10-08 10:43 UTC] kubacki at uwth dot uni-hannover dot de
Description:
------------
If safe_mode is On every WWW-Authenticate header is being added the uid of the running script. Sometimes you don't want this feature.

What about adding a configure option for turning this feature off?
(Maybe safe_mode_realm_mangling, editable only in the ini-file.)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-18 23:39 UTC] jani@php.net
-Status: Open +Status: Wont fix -Package: Feature/Change Request +Package: Safe Mode/open_basedir
 [2010-11-18 23:39 UTC] jani@php.net
Safe-mode will be gone since 5.4, won't change in < 5.4 either.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 14:01:24 2020 UTC