php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25755 DB_NestedSet MDB Support
Submitted: 2003-10-05 08:50 UTC Modified: 2003-10-07 04:34 UTC
From: simon dot hamilton at ntlworld dot com Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.2 OS: Windows XP SP1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: simon dot hamilton at ntlworld dot com
New email:
PHP Version: OS:

 

 [2003-10-05 08:50 UTC] simon dot hamilton at ntlworld dot com
Description:
------------
When I change the driver from DB to MDB, I get the following message as detailed below.

DB_NestedSet  v.1.2.4
MDB           v.1.1.3



Reproduce code:
---------------
		$treeNodes = $this->nestedSet->getAllNodes(true, true, array(
																	'cols' => 'table.url, table.url_text'
																));

		// render output
		$options = array(
		    'structure' => $treeNodes,
		    'textField' => 'url_text',
		    'linkField' => 'url',
			'options' => array('icon' => 'folder.gif',
								'expandedIcon' => 'folder-expanded.gif')
		);


		$this->output =& DB_NestedSet_Output::factory($options, 'TreeMenu');

Expected result:
----------------
A DHTML tree Menu (works fine using DB rather than MDB)

Actual result:
--------------
Fatal error: Call to undefined function: quote() in E:\.....\libs\pear\DB\NestedSet.php on line 613

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-06 03:48 UTC] datenpunk@php.net
MDB support is broken in the 1.x branch. This is because some recent changes in MDB and DB_NestedSet.
This is also mentioned at http://oss.webcluster.at.
We will do our best to get this fixed for 1.3 which is about to be released. If the fix implies an API change the next version with MDB support will be 2.0. This release will work with the soon to be released MDB 2.0 then.
 [2003-10-07 04:22 UTC] datenpunk@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php


 [2003-10-07 04:34 UTC] datenpunk@php.net
O.K. this didn't make sense at all.
The standard answers don't fit for pear :]
Please try the new released DB_NestedSet-1.3 beta. 
MDB support is back again.
BTW pear now has it's own bug reporting system.
Follow the link 'Package Bugs' (see http://pear.php.net/package/DB_NestedSet) to file a bug for pear.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 02:01:23 2021 UTC