php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25743 "php_flag engine off" problem
Submitted: 2003-10-03 08:40 UTC Modified: 2003-10-03 09:52 UTC
From: vicus at artemcity dot ru Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.3 OS: RedHat Linux 9.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vicus at artemcity dot ru
New email:
PHP Version: OS:

 

 [2003-10-03 08:40 UTC] vicus at artemcity dot ru
Description:
------------
I put the string "php_admin_flag engine off" to one of my VirtualHosts. Then i'm restarting Apache 2.0.47 and try to execute script on above host. Thats ok, script retriving in text/plain mode. But from that moment other VirtualHosts begin randomly not execute php-script and give it to me in source... After restarting server and for the moment of first retrive script on "engine off'ed" VH all works fine.

Sorry for my english :)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-03 09:52 UTC] mgf@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

This is similar to a number of existing bug reports, for example #25417.

When you put a php_* directive in a VirtualHost in httpd.conf, you currently need to add the same directive in *all* other VirtualHosts, with suitable settings for each (if necessary, using the special keyword "none" to specify no setting for that VirtualHost).  In this case, you would need "php_admin_flag engine on" in all your other VirtualHost containers.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 25 06:03:33 2022 UTC