php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25684 segmentation fault in java.php
Submitted: 2003-09-29 03:31 UTC Modified: 2003-09-29 05:52 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: fperez at tuzsa dot es Assigned:
Status: Wont fix Package: Java related
PHP Version: 4.3.3 OS: RedHat Linux 7.3
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: fperez at tuzsa dot es
New email:
PHP Version: OS:

 

 [2003-09-29 03:31 UTC] fperez at tuzsa dot es
Description:
------------
Hello,

Apache 1.3.28, php-4.3.3, RedHat 7.3, java 1.4.2_01.

I have configured ld.so.conf with the java_paths and I have configured, also, export LD_LIBRARY_PATH java_paths on /usr/local/apache/bin/apachectl

I have a segmentation fault which is difficult to report you because:

1.- If I compile php without --enable-debug I always obtain a segmentation fault running java.php (java.php=example 1 in http://www.php.net/manual/en/ref.java.php).

2.- If I compile php WITH --enable-debug then the same script (java.php) runs fine without any problem.

Because of that I cannot send you a backtrace or something else with --enable-debug. :-(

What I should to do ?  How can I sent you more information ?

Thanks

PS: Of course, I have the same problem with other php/java scripts and, again, if I compile php with --enable-debug, all crashes goes out.

Reproduce code:
---------------
EXAMPLE 1. in:
http://www.php.net/manual/en/ref.java.php

Actual result:
--------------
Sometimes I obtain a whole empty page and this apache error_log (note the strange characters on the first line after NoSuchMethodException):

[Mon Sep 29 09:19:37 2003] [error] PHP Warning:  java.lang.NoSuchMethodException: ?7 in /www/tuzsa/java.php on line 16
[Mon Sep 29 09:19:37 2003] [notice] child pid 1661 exit signal Segmentation fault (11)

Sometimes I obtain this results (note the date/time formated result aren't)
===================================
Java version=1.4.2_01 
Java vendor=Sun Microsystems Inc. 
OS=Linux 2.4.18-3smp on i386 
===================================
And I have this, again, in the apache error log:

[Mon Sep 29 09:23:01 2003] [error] PHP Warning:  java.lang.NoSuchMethodException: ?H? in /www/tuzsa/java.php on line 16
[Mon Sep 29 09:23:03 2003] [notice] child pid 1662 exit signal Segmentation fault (11)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-29 04:57 UTC] fperez at tuzsa dot es
A new note:

if I configure php without --enable-debug and execute the java.php url page within Zend Studio (Zend Development environment) then execution script and results goes ok again.

Thanks.
 [2003-09-29 05:31 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

This has been reported many many times before,
check back when PHP 5 is released..

 [2003-09-29 05:43 UTC] fperez at tuzsa dot es
I have tried to find any bug report with this same result.  I have found several bug reports what seems to be pretty near to my results, but with different (old) versions or different operating system.

After your note, I have tried to find any bug report with:
java enable-debug  (or)
java segmentation fault

I have found a lot of bug reports, specially with the second searches.  But all of them are closed or bogus and the opened reports I could find seems different for me.

Please, could you send me the bug report number to follow its progress ?  I am sure it is there but I cannot find it.

Thanks a lot and congratulations for your job.
 [2003-09-29 05:52 UTC] sniper@php.net
Any report which says 'crashed' is related.
The java extension in PHP 4 is unmaintained and considered
extremely experimental..it doesn't even exist in PHP 5 (yet)
for which it will be rewritten.

Wait for PHP 5. Changed status to 'wont fix' which is more appropriate for this.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 08:01:30 2019 UTC