php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25613 no output after using require_once(..)
Submitted: 2003-09-20 03:44 UTC Modified: 2003-09-20 04:26 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: joe at kybert dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.3.2 OS: XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joe at kybert dot com
New email:
PHP Version: OS:

 

 [2003-09-20 03:44 UTC] joe at kybert dot com
Description:
------------
Try this:

in a web page, include a file using this

<?php

// or what ever addy you feel fit (the included page can be empty)

$open = "/pages/extras.inc.php";      
require_once($open);

$echo "hello world!";

?>


i never get to see the "hello world" message.... works fine in PHP4.3.0, not in 4.3.2 

joe
#


Expected result:
----------------
hello world! should be displayed

Actual result:
--------------
blank page

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-20 03:46 UTC] sniper@php.net
Try removing the $ in front of echo.. (it's not variable..)

 [2003-09-20 03:49 UTC] joe at kybert dot com
thats a typo on my part, the issue is still there, after a call to:

require_once(....)

the parser apears to stop dead... NO OUTPUT !

joe
#
 [2003-09-20 03:54 UTC] sniper@php.net
There is no bug here. Try adding 'error_reporting(E_ALL);' as first line in your script and you'll propably find out why it fails. And possibly ini_set('display_errors',1); too. 

 [2003-09-20 03:55 UTC] sniper@php.net
Also read the manual page about require() 

 [2003-09-20 04:26 UTC] joe at kybert dot com
ok, its $DOCUMENT_ROOT var contains nothing 4.3.2 so i guess it is bogus, not sure why this var sudenly dissapears, but it has and its crippled a 20'000+ page site.

joe
#
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jul 22 20:01:29 2024 UTC