php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25594 chmod does not handle sticky bits/setuid/setgid
Submitted: 2003-09-18 11:25 UTC Modified: 2003-09-18 12:06 UTC
From: shofmann at databay dot de Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 4.3.1 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: shofmann at databay dot de
New email:
PHP Version: OS:

 

 [2003-09-18 11:25 UTC] shofmann at databay dot de
Description:
------------
consider this:

mkdir ("test",02755) creates a directory with the permissions 'drwxrwsr−x'.

ok.

But chmod("test",02775) results in 'drwxrwxr−x'.

No matter which values I choose, sticky bits/setuid/setgid are ignored by chmod.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-18 11:27 UTC] shofmann at databay dot de
Sorry, the 'minus' is translated into unicode during submission process.

'drwxrwsr−x' is read as 'drwxrwsr-x' and
'drwxrwxr−x' should be 'drwxrwxr-x'.
 [2003-09-18 12:06 UTC] shofmann at databay dot de
ups, this issue is caused by a safe mode restriction and I have safe mode activated :-)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 13:01:23 2020 UTC