php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25586 OleMainThreadWndName: Apache.exe application error when accessing a COM object
Submitted: 2003-09-18 09:01 UTC Modified: 2003-09-19 00:51 UTC
Votes:3
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: plamentodorov at lycos dot com Assigned:
Status: Wont fix Package: COM related
PHP Version: 4.3.2 OS: Windows NT 4.0 SP6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: plamentodorov at lycos dot com
New email:
PHP Version: OS:

 

 [2003-09-18 09:01 UTC] plamentodorov at lycos dot com
Description:
------------
I am trying to load a COM object from the php and I get an "OleMainThreadWndName: Apache.exe application error" when calling an arbitrary method. 
Actualy I don't know if the problem is in the php. I have written the COM server by myself (using Borland Delphi 6.0) but it works fine with the test program.
The strange thing is that if I call com_set() or com_get() functions before calling the object method the scripts works just fine.
Other info:
Apache 1.3.26 + PHP/4.3.2RC3 (running as an Apache module)
Extensions: php_openssl; php_xslt; 

Reproduce code:
---------------
<?php
//loading com object
$try = new COM('tryCOM.tryCoClass') or die('Unable to load COM object');
$value = 100;
//the damn thing works if I uncomment this
//com_set($try, 'Property1', $value);
$value = 1000;
$try->Method1($value);
unset($try);
?>

Actual result:
--------------
Message from the OS:
"OleMainThreadWndName: Apache.exe application error. The instruction 0x00020400 referenced memory as 0x0000000a. The memory could not be "written"."

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-19 00:51 UTC] sniper@php.net
The COM extension has been completely rewritten in PHP5 and the PHP4 COM extension is no longer being maintained. If you find bugs with the com extension in PHP5 please report them.

Latest PHP 5 snapshot can be found at http://snaps.php.net/
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 22:01:25 2020 UTC