php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25520 PHP 4.5.x-dev snapshots should not be available
Submitted: 2003-09-12 17:34 UTC Modified: 2004-03-18 17:22 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: jarmak at 2i dot pl Assigned: imajes (profile)
Status: Closed Package: Systems problem
PHP Version: Irrelevant OS: RedHat 9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jarmak at 2i dot pl
New email:
PHP Version: OS:

 

 [2003-09-12 17:34 UTC] jarmak at 2i dot pl
Description:
------------
I tried to compile PHP (php-4.3.3 snapshot: 200309120730) + Apache2 (httpd-2.0.47) + OpenSSL (openssl-0.9.7b).

I compiled and installed OpenSSL and Apache2 from sources - It was working.

I had started compiling PHP:

./configure \
--prefix=/usr/local/php \
--with-apxs2=/usr/local/apache2/bin/apxs \
--with-zlib \
--with-pgsql=/usr/local/pgsql \
--without-mysql \
--with-config-file-path=/usr/local/apache2/conf

result: no errors

when I made 'make' I got:

/home/jarmak/installs/php/php4-200309120730/ext/standard/var_unserializer.c: In function `php_var_unserialize':
/home/jarmak/installs/php/php4-200309120730/ext/standard/var_unserializer.c:308: warning: comparison is always false due to limited range of data type
ext/standard/filestat.lo(.text+0xdc1): In function `php_stat':
/home/jarmak/installs/php/php4-200309120730/ext/standard/filestat.c:575: undefined reference to `php_check_open_basedir_ex'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

How can I fix this error?

In bug http://bugs.php.net/bug.php?id=23792 I found similar bug, but It was fixed in new snapshots of the sources ... but I not in 200309120730.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-14 03:19 UTC] sniper@php.net
Get the correct snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz

Making this website problem, someone with access should nuke
 'Latest CVS' (the infamous PHP_4 branch) from snaps.php.net.

 [2004-01-19 10:54 UTC] goba@php.net
Changed summary to be more descriptive
 [2004-01-19 12:02 UTC] goba@php.net
Systems issue (recategorized)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 24 08:01:23 2021 UTC