php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25501 The SQLite_open() truncate non SQLite Data Bases file
Submitted: 2003-09-11 19:03 UTC Modified: 2003-09-11 20:03 UTC
From: o_gangrel at hotmail dot com Assigned:
Status: Not a bug Package: SQLite related
PHP Version: 5.0.0b1 (beta1) OS: Windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: o_gangrel at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-09-11 19:03 UTC] o_gangrel at hotmail dot com
Description:
------------
I am using the configuration Apache/2.0.43 (Win32) PHP/5.0.0b1 with PHP as a module of Apache.

Using the sqlite_open() if the file exists and this file is not a SQLite Data Base file it is opened normally, the querys always return normally with an empty result set. But when a table is created (I guess the other CREATE sql commands accepted by the SQLite) it truncates the file and change the file to a SQLite Data Base file.

I found solutions to not hapen this erro, but this is not expected.
And I'm sorry, I didn't tested the CVS version and other vertion of the Apache and SQLite module.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-11 20:03 UTC] wez@php.net
Not a bug in PHP but in the sqlite library.
Please report the problem here:
http://www.sqlite.org/cvstrac/tktnew
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 18:03:43 2022 UTC