php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #2541 dl(string name) should not require the file extension for the module name
Submitted: 1999-10-16 03:43 UTC Modified: 2002-08-17 15:53 UTC
From: yves at realnames dot com Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0 OS: Linux 2.2.12 / Windows NT
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: yves at realnames dot com
New email:
PHP Version: OS:

 

 [1999-10-16 03:43 UTC] yves at realnames dot com
The subject says it all. Since dl() requires the module filename with its extension, and since extensions differ on platforms, it makes writing scripts using dl() a pain.

If PHP would check for the name as given, and then with a a system-specific extension, one could write:

dl("extension")

and have it be extension.so on Linux and Solaris for example, and extension.dll on Windows.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-10 13:50 UTC] jimw@php.net
refiling against 4.0. PEAR may end up needing something similar when it supports extensions with non-php components.
 [2001-02-11 13:18 UTC] cynic@php.net
dl() doesn't work in multithreaded servers anyway (pretty much all win32 webservers)
 [2002-08-17 15:53 UTC] tal@php.net
Hmm... but the extensions in *nix systems mean nothing.
I can rename my module to module.foo.
Bogusifying, baby.

-Tal
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 21:03:39 2021 UTC