php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25408 mail function drops some characters from body
Submitted: 2003-09-07 01:10 UTC Modified: 2003-09-08 03:44 UTC
From: zabihi at iranculture dot org Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.3 OS: Win2000 Adv. - SP4 - IIS5.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zabihi at iranculture dot org
New email:
PHP Version: OS:

 

 [2003-09-07 01:10 UTC] zabihi at iranculture dot org
Description:
------------
When body of message is more than 1024 characters, the 1024th character is dropped when sending mail. This problem occurs with every 1024 characters in the body, so 2048th and 3072nd characters are also dropped.
Mail server is MDaemon 6.7 and no error is reporting. 



Reproduce code:
---------------
$body="ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz1234567890\n";
$body.=$body;
$body.=$body;
$body.=$body;
$body.=$body;
$body.=$body;
$body.=$body;
if (mail("admin@iranculture.org","Testing PHP Mail", $body, ""))
	echo "OK!";
else
	echo "Error!";



Expected result:
----------------
When we receive the message the following string should be repeated 64 times:
"ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz1234567890"


Actual result:
--------------
When we receive the message the following string is repeated 64 times but in line 17 the "P" character is dropped and in line 33 the "f" character is dropped and so on:
"ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz1234567890"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-07 11:12 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

*sigh*

 [2003-09-08 00:15 UTC] zabihi at iranculture dot org
I reviewed bugs #25346, #25357 and #25333, but I couldn't find any solution except downgrading to 4.3.2 or using imap_mail() instead.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Feb 02 02:05:53 2023 UTC