|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25305 "No input file specified." error with Xitami
Submitted: 2003-08-28 16:48 UTC Modified: 2003-08-28 17:47 UTC
From: goweb at o2 dot co dot uk Assigned:
Status: Closed Package: Other web server
PHP Version: 4.3.3 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: goweb at o2 dot co dot uk
New email:
PHP Version: OS:


 [2003-08-28 16:48 UTC] goweb at o2 dot co dot uk
Whatever script I try to run on my Xitami web server, I get the following text returned:

No input file specified.

This is all that is returned. I am using the PHP4-recommended php.ini file and have only changed the extension_dir, doc_root and cgi.force-redirect. All these scripts worked with PHP 4.3.2


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-28 17:28 UTC] goweb at o2 dot co dot uk
EDIT: Now PHP 4.3.2 no longer works
 [2003-08-28 17:47 UTC] goweb at o2 dot co dot uk
Problem solved - for some reason cgi.fix_pathinfo MUST be set to 1 for it to work with Xitami.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 08 10:01:28 2023 UTC