php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25276 uninstalling not installed package fails
Submitted: 2003-08-27 12:45 UTC Modified: 2003-09-02 18:39 UTC
From: php at cipri dot com Assigned:
Status: Closed Package: PEAR related
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: php at cipri dot com
New email:
PHP Version: OS:

 

 [2003-08-27 12:45 UTC] php at cipri dot com
Description:
------------
If you uninstall a package that's not installed, the installer will print an extra 1 on the next line which it shouldn't.


Reproduce code:
---------------
[root@BorgCube pear]# pear uninstall Net_FTP
uninstall ok: Net_FTP
[root@BorgCube pear]# pear uninstall Net_FTP
Net_FTP not installed
1[root@BorgCube pear]#


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-27 15:46 UTC] cellog@php.net
This does not occur in Windows XP with PEAR 1.2.1, what OS are you using?  can you paste in output from pear list?

Regards,
Greg
 [2003-09-02 18:14 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-09-02 18:39 UTC] cox@php.net
I'm sure this was fixed already in the latest release. Do a "pear upgrade PEAR" and try again.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 17:03:35 2021 UTC