php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25257 Net_FTP bad md5sum
Submitted: 2003-08-26 14:13 UTC Modified: 2004-03-17 13:22 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: toni dot viemero at iki dot fi Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.3 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: toni dot viemero at iki dot fi
New email:
PHP Version: OS:

 

 [2003-08-26 14:13 UTC] toni dot viemero at iki dot fi
Description:
------------
downloading Net_FTP-1.1.tgz ...
...done: 10,147 bytes
warning : bad md5sum for file /usr/local/share/pear/Net/FTP.php
install ok: Net_FTP 1.1

Reproduce code:
---------------
pear install Net_FTP


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-26 15:02 UTC] davey@php.net
Verified on WinXP SP1, PEAR 1.2.1. - possibly something to do with the server move?

Why does PEAR install packages with a bad md5sum? surely you should need to --force it?

- Davey
 [2003-08-26 15:30 UTC] php at cipri dot com
Verified on both PEAR-1.2b5 and PEAR 1.2.1 runnign on Debian LInux.
 [2003-08-27 07:06 UTC] cox@php.net
Probably Net_FTP only needs repacking, but true, PEAR have not allow to install a package with an invalid checksum.
 [2003-08-27 07:30 UTC] cox@php.net
Probably this bug is related to #25117, but please do not close this report until we don't fix the problem of allowing install with a md5 check failure.
 [2003-08-27 12:13 UTC] php at cipri dot com
Probably this bug is related to #25117, but please do not close this report until we don't fix the problem of allowing install with a md5 check failure.

I added some debugging to the Installer.php, which told me that the file indeed was corrupted. (See output section below)

Perhaps it'd be better to open a seperate bug report for the `pear installs files with invalid checksum` since there really /is/ a bug in Net_FTP?


-- Output --

[root@BorgCube PEAR]# pear install Net_FTP  
downloading Net_FTP-1.1.tgz ...
...done: 10,147 bytes
1) 5803a464016932371c21402132cd82cf
2) 50f867d55362a0b22981cbec2f328ccc
warning : bad md5sum for file /usr/share/pear/Net/FTP.php
1) 18c177f195bf8ec9e7b13cb69c4ea875
2) 18c177f195bf8ec9e7b13cb69c4ea875
1) d9ce2e12e38b34b25277a2eefa1740a3
2) d9ce2e12e38b34b25277a2eefa1740a3
 [2003-08-27 13:18 UTC] cellog@php.net
This is easily fixed - currently a bad md5sum is simply a warning.  #25117 is unrelated to this bug, that was simply a problem caused by the md5sum being generated by a package that used capital letters instead of lowercase.

A new bug should be opened that states md5sum mismatch should be a fatal error in the installer.  I can fix it in 5 minutes, promise :)

Greg
 [2004-03-17 13:22 UTC] toby@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jul 26 02:01:23 2021 UTC