php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25232 --enable-force-cgi-redirect gives Warnings
Submitted: 2003-08-25 04:10 UTC Modified: 2003-08-25 17:52 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: alex at della dot com dot ua Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 4CVS-2003-08-25 (stable) OS: FeeBSD 4.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alex at della dot com dot ua
New email:
PHP Version: OS:

 

 [2003-08-25 04:10 UTC] alex at della dot com dot ua
Description:
------------
When I configure like:

srv# ./configure --enable-memory-limit --with-config-file-path=./ --with-mysql --enable-force-cgi-redirect --enable-discard-path --enable-fastcgi


Make gives me the Warning messages:

/usr/src/MySRC/php4-STABLE-200308250530/ext/standard/var_unserializer.c: In function `php_var_unserialize':
/usr/src/MySRC/php4-STABLE-200308250530/ext/standard/var_unserializer.c:308: warning: comparison is always false due to limited range of data type
/usr/src/MySRC/php4-STABLE-200308250530/sapi/cgi/cgi_main.c: In function `main':
/usr/src/MySRC/php4-STABLE-200308250530/sapi/cgi/cgi_main.c:1048: warning: passing arg 2 of `cfg_get_long' from incompatible pointer type
ext/mysql/libmysql/my_tempnam.o: In function `my_tempnam':
/usr/src/MySRC/php4-STABLE-200308250530/ext/mysql/libmysql/my_tempnam.c(.text+0x46): warning: tempnam() possibly used unsafely; consider using mkstemp()
ext/mysql/libmysql/my_tempnam.o: In function `my_tempnam':
/usr/src/MySRC/php4-STABLE-200308250530/ext/mysql/libmysql/my_tempnam.c(.text+0x46): warning: tempnam() possibly used unsafely; consider using mkstemp()

 But when I do: 

srv# ./configure --enable-memory-limit --with-config-file-path=./ --with-mysql --enable-discard-path --enable-fastcgi

  Make gives:

/usr/src/MySRC/php4-STABLE-200308250530/ext/standard/var_unserializer.c: In function `php_var_unserialize':
/usr/src/MySRC/php4-STABLE-200308250530/ext/standard/var_unserializer.c:308: warning: comparison is always false due to limited range of data type
ext/mysql/libmysql/my_tempnam.o: In function `my_tempnam':
/usr/src/MySRC/php4-STABLE-200308250530/ext/mysql/libmysql/my_tempnam.c(.text+0x46): warning: tempnam() possibly used unsafely; consider using mkstemp()
ext/mysql/libmysql/my_tempnam.o: In function `my_tempnam':
/usr/src/MySRC/php4-STABLE-200308250530/ext/mysql/libmysql/my_tempnam.c(.text+0x46): warning: tempnam() possibly used unsafely; consider using mkstemp()

  How can I build a CGI version with --enable-force-cgi-redirect? Is it safe to ignore warnings about var_unserializer?

  I will be wery grateful for help.

Thanks.

P.S. I tried to use the latest CVS version (php4-STABLE-200308250730).


Expected result:
----------------
  I just need a secure CGI version of PHP. It builds, but wont't work. I think, that the problem in a warning messages. Is I'm right? Or I have a problem with configuration? Is it safe to ignore all the warnings I write above?

Actual result:
--------------
  I can make a mistake, but it seems that CGI version vont't work. Any script gives me "Maximum execution time exceeded" error message. It is strange, but the same CGI version works if it runs from command line.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-25 17:52 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You can ignore these warnings just fine
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 08:01:25 2020 UTC