php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25217 calling ob_gzhandler after modified buffer in ob handler, return origin buffer
Submitted: 2003-08-23 04:13 UTC Modified: 2003-08-24 22:50 UTC
From: Xuefer at 21cn dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.3.3RC4 OS: win
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Xuefer at 21cn dot com
New email:
PHP Version: OS:

 

 [2003-08-23 04:13 UTC] Xuefer at 21cn dot com
Description:
------------
only when client do not support compressing
save the below sample as: ob_gzhandler.phpt
and: make test

--TEST--
ob_gzhandler
--POST--
--GET--
--FILE--
<?php
function test($buffer, $flags) {
	$buffer = '456';
	$buffer = ob_gzhandler($buffer, $flags);
	return $buffer;
}

ob_start('test');
echo 123;
?>
--EXPECT--
456


=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
ob_gzhandler [test/ob_handler.phpt]

actual output is 123, not 456


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-24 22:50 UTC] sniper@php.net
RTFM: "ob_gzhandler() is intended to be used as a callback function for ob_start()"

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 02:05:43 2022 UTC