php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25143 both ftp_nlist() and ftp_rawlist() do not work!
Submitted: 2003-08-19 01:34 UTC Modified: 2003-08-19 04:31 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: zhuzhi at scxxt dot com dot cn Assigned:
Status: Not a bug Package: FTP related
PHP Version: 4.3.2 OS: linux 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zhuzhi at scxxt dot com dot cn
New email:
PHP Version: OS:

 

 [2003-08-19 01:34 UTC] zhuzhi at scxxt dot com dot cn
Description:
------------
I just tried to FTP some files to a linux server with a php file. When I tried this in local machine(W2K + apache 1.3.27 + php4.2.3), all were right, but when I upload my scripts to the web server(RH linux 7.3 + apache 2.0.49 + php 4.3.2) and tried it again, the scripts did nothing. I tried to add "echo" in the scripts and I found ftp_rawlist() and ftp_nlist() did not work at all. But all were right in my local machine!

Reproduce code:
---------------
the following is the code 
<?
$conn=ftp_connect($server,$port);
ftp_login($conn,$name,$passwd);

$rawlist=array();
$nlist=array();

$rawlist=ftp_rawlist($conn,"/");
$nlist=ftp_nlist($conn,"/");

foreach($rawlist as $item) {
echo $item;
}
?>

Expected result:
----------------
so please give me some ideas of this problem ASAP,thanks. Because I need this urgently!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-08-19 02:48 UTC] zhuzhi at scxxt dot com dot cn
thanks for your help.
But unfortunately, THE PROBLEM REMAIN! I have tried several times with php4.2.3\php4.3.2 and the version you supplied.
Anyone else can help me???
 [2003-08-19 04:31 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Works fine here.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 28 06:03:41 2022 UTC